“This form has been closed” and “The specified form cannot be found” When Using SharePoint Default Workflows

A really weird bug with SharePoint happened today.

SYMPTOMS

You have a standard MOSS 2007 Approval or Collect Feedback workflow configured in a document library or a content type. You try to:

  • Open a task created by the workflow
  • Modify the workflow association data of an existing workflow
  • Create a new workflow association

SharePoint displays “This form has been closed” or “The specified form cannot be found” trying to display the form. Sometimes it shows the InfoPath Forms Service message box with the same information.

CAUSE

The standard out-of-the-box workflows have been messed up after their creation, by unknown causes.

SOLUTION

Uninstall and reinstall the standard workflow feature, using the following sequence of command line operations:

  • stsadm –o deactivatefeature –name ReviewWorkflows –url YOURPORTALURL –force
  • stsadm –o uninstallfeature –name ReviewWorkflows –force
  • stsadm –o installfeature –name ReviewWorkflows –force
  • stsadm –o activatefeature –name ReviewWorkflows –url YOURPORTALURL

Thanks to Patrik Luca on MSDN Forums.

3 thoughts on ““This form has been closed” and “The specified form cannot be found” When Using SharePoint Default Workflows”

Leave a Reply to Anonymous Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.